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IMPORTANT NOTE:

Check that you have the latest version of Zooprocess
(https://sites.google.com/view/piqv/zooprocess)

Date Name operator Object Chapter
2019/01/25 Elineau Amanda update 2
2020/05/20 Elineau Amanda update 2
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1. Maintain PkID Validation

You have some projects already predicted/classified with PkID and you want to export them into Ecotaxa keeping
the classification. (If your projects are unclassified, see directly the next chapter).

At this step :

e Thereis 1 datl.pid file per sample in the folder: Zooscan_nameoftheproject/PID_process/Pid_results
e Thereis 1 subfolder called “nameofthesample_validated” in the folder:
Zooscan_nameoftheproject/PID_process/Sorted_vignettes
In each subfolder you have all the images .jpg + 1 .txt file called “Analysis_nameofthesample_dat1.txt”

NB: The number of objects between the pid file and the Analysis txt file must be the same

Open Zooprocess in Advanced Mode: T oo — D T .

e Load identifications from sorted vignettes

Project: L:iZooscan_icecamp_2015_2016

It will create 2 .txt files per sample in the folder: ece
Zooscan_nameoftheproject/PID_process/Pid_results/ T E

Datl_validated

Press Cancel and Start again Zooprocess to CREATE or CHANGE project

ADVANCED MODE

OK | Cancel

READ IDENTIFICATIO

Project : scan_icecamp_2015_2016

¥ Use default project architecture
¥ Loadfile list of categories >
I~ Keep only Area, Mean, Major, Minor, Feret, Area exc and ThickR in loaded files »

Selectfolders to process  Load Ids from “validated” and “ffom_dat1_validated" folders only -
¥ Loadlds from all subfolders in L\Zooscan icecamp 2015 2016PID processiSorted vignettes\ 2
I~ Skip already loaded dat1 bt files (used only if "Load Ids from all subfolder option enabled)

Enter FIRST name of expert who validated the identifications 2

Enter LAST name of expert who validated the identifications 2

ok | cancel

, :
ECT R ——

e Select Create tables for Ecotaxa

Project: icecamp_2015_2016

VUESCAN version : 9.0.51

SELECT PROCESS [SIEETERETIEER T elo) FVTY -

Press Cancel and Start again Zooprocess to CREATE or CHANGE project

ADVANCED MODE

OK Cancel




e Select ALL sorted vignettes (uses* datl.txt files from |- =

“datl_validated” folder and vignettes from et s s 2 e
”SOI’ted_Vlgnettes") Instrument zo0scan

SELECT OPTION

[ALL sorted vignettes (uses *_dat1.bstfiles from “dat1_validated folder and vignettes from *sorted_vigneties”) |4

Enter link to be added to the vignettes  an.obs-ififri’

I Create additional vignette with B&W mask (valid ONLY for TSV frem sorted vignettes)
[V Set Status to “prediced” instead of “Validated" (for sorted vignettes imported from Zooprocess)

ok | cancel

It will create 1 subfolder per sample in the folder:

Zooscan_nameoftheproject/ecotaxa

2. FTP Connexion

Edit View Transfer Server Bookmarks Help MNew version available!
e Download and install FileZilla (https://filezilla- Site Manager. CTRL:S
) Copy current connection to Site Manager... S Port: re—
ro eCt'Or ) Mew tab CTRL+T -
H H Close tab CTRL+W
e Select File > Site Manager...
Export...
Import...
Show files currently being edited... CTRL+E e
Exit CTRL+Q
IOpen;the Site Manager & Queue 220,7 MiB e

o Create a New Site called : Ecotaxa_VLFR

e In General tag: Select Entry:
e General |Advanced |Transfer Settingsl Charset|
. = it
HOSt . planktonObs Vlfr‘fr H !yd;‘::med_oceane Protocol: [FI'P - File Transfer Protocol
Protocol : FTP — File Transfer Protocol ; ecotsxs Host: plankzon.obs-vifrfr
. . . Ecotaxa_tara_roscoff
Encryption : Only use plain FTP (insecure) . B Ecotaxa VLFR Encryption: [Only use plain FTP (insecure)

B oceane

Logon Type : Normal
User: ftp_plankton Ueer ftp_plonkton
Password : Pl@nktOn4Ecotaxa Password: | sessessessassass

Logon Type: [Normal

Background colon

Cornrments:

[ New Site ] l MNew Folder ]

[ Mew Bookmark ] l Rename ]

[ pelete || Duplicate |

Connect ] [



https://filezilla-project.org/
https://filezilla-project.org/

e NB: You will have a direct access by the main window

Host : plankton.obs-vlfr.fr
Username : ftp_plankton
Password : Pl@nktOn4Ecotaxa

File Edit View Transfer Server Bookmarks Help New version available!

1 -FEER |+ B&kg BTN
Host: slankton.obs-vifrfr  Username: ftp_plankton Password: eessssssssssss Port B

e Filezilla doesn’ t like the name of files with the symbol (for ex : wp2_ 20200520 _200um)
e Select File > Site Manager... > Charset
Select Force UTF-8

Site Manager X

Select entry: General Advanced Transfer Settings Charset

My Sites

The server uses following charset encoding for filenames:
! Ecotaxa_VLFR

O Autodetect

Uses UTF-8 if the server supports it, else uses local
charset,

® Force UTF-8
() Use custom charset

Encoding:

Using the wrong charset can result in filenames not
displaying properly.

New site New folder
New Bookmark Rename
Delete Duplicate




3. Procedures and organization of data into FTP

EIRWTSw—————r oo e

3.1 FIOWCAM & Zooscan File Edit View Transfer Server Bookmarks Help
. . . EEFOECRO Vv Fass
e Create a folder starting with your Institute name [— e

Status: Calculating timezone offset of server... -
e Draganddrop in this folder : E::::; bbb I
Local site: | C:\Users\Amanda\ « [ Remote site: [ 1OV =
2 dmene == H /’; AFB Iroise 3
*Not validated data : Pt Al e
I P —T— » 1.2 BCRE 3
the _work folder from your Zooprocess project p— = =R e

12 Ecotaxa_Exported_deta

*Validated data (from PKId): H [ 7 o e

the ecotaxa folder from your Zooprocess project M
NB: Check that all your metadata have been B ot Eﬂ‘;ﬁ;ﬁfjm"‘ Do
correctly documented before this step. TW | £ ‘IElZLiZZM“”"“"““““ 532321322'3_

24 files and 29 directories. Total size: 37 632 623 bytes |5 files and 20 directories. Total size: 326 688 bytes

3 2 U V P Server/Local file Directic *
: W fip_plankton@plankton obs-vifr fr 3

Ci\Users\Amanda\Desktop\phyco_st30_1\phyco_st30_1_sep.qif .
H H H X\Zooscan_docs\temp_rireive 1_st20_raw_1zip <
e Create a folder starting with your Institute name et sy 117yl s LTS Vg 28L 10530481 N

TAflowcam_pth_phyto_2017_pelagos\work\phyto20170530\phyto20170530_1088,jpg

° D ra g an d d ro p i n t h is fo I d er yo ur W H O LE P ROJ ECT. TAflowcam_pth_phyto_2017_pelagos\workphyto20170530\phyto20170530_3672,jpg i

TAflowcam_pth_phyto_2017_pelagos\workphyto20170530\phyto20170530_4024.,jpg
TAflowcam_pth_phyto_2017_pelagos\workphyto20170530\phyto20170530_3062,jpg

It will permit to import both the images and the | [ s R ot g% e

Queued files (335976) | Failed transfers | Successful transfers

particle data in the Particle module of Ecotaxa. 00 ameiice 00

NB: Check that all your metadata have been correctly fill in before this step.

4. Memory management
After the importation and the checking of your data in Ecotaxa, delete your folder from the FTP.

= Anyone having these writing permission on our FTP can load and download any data from this FTP. It is thus
IMPORTANT to remove your data as soon as it has been imported into Ecotaxa.

5. Importation procedure into Ecotaxa (images & TSV)

e Select Project > Import images and metadata

Project | ~
Show confusion matrix
Learn and predict identifications

Predict identifications from trained model

Export

Import images and metadata

Edit project settings

Extract Subset

Merge another project in this project
Edit or erase annotations massively
Batch edit metadata

Reset status to Predicted

Delete objects or project

e Select the folder icon FeoTaxg Moo
CcolaxX

Images and TSV file import (Step 1)

How to create a project @
How to prepare data @

How to import data from zooprocess @

Choose a folder or zip file on the server

-

Contact the project manager to know where and how to upload your data. Once the import is complete, all data folde Js/files

can be safely erased on the server.

Project manager : Amanda Elineau (amanda.elineau@obs-vlfr.fr)
[C] skip tsv files that have already been imported
[ Skip objects that have already been imported

Advanced options @




Access to your folder by clicking on the arrow
ftp_plankton

For FlowCAM, ZooScan and UVP5 :

Open your project by clicking on the arrow
Then you can Select the work or ecotaxa
Folders that you imported.

Select a folder or a zip file

-ftp_plankton
..... home [EX=3




6. Exportation procedure

e Select Project > Export Show confusion matrix

Learn and predict identifications

Predict identifications from trained model

Export

Import images and metadata

Edit project settings

Extract Subset

Merge another project in this project
Edit or erase annotations massively
Batch edit metadata

Reset status to Predicted

Delete objects or project

e Select a format then check the box “Save export file on “Exported data” folder on the FTP Area”

Text export Task creation
Exported Project : #582 - Myproject

@715V [¥] Object Data (median,mean, x, y, ...)
[¥] Process Data [softwareversion, ...)
[¥] Acquisition Data (Resolution, ...)
[#] sample Data (lat,long, date, ...)
[T Historical Data
["] comments
[ Use comma as decimal separator
[ internal IDs
[) 2nd line, Make exported file compatible for reimportation
Splitin multiple files by Sample -
[ Export all image files
[} Use internal ids to name image files (usefull if duplicated imported image files)

(XML

) Summary Count per category and Whole Project »

in order to ease the transfer of large exported datasets, you can chese to export your files to the Ecotaxa FTP that is utilized to import your data and images.
Do not forget to delete your exported files from the FTP as they will be visible and available for other users.
sk Footaxs managers [piqu@obs-vifr.fr ) if you do not have yet the permissions on this FTP

V| Save export file on "Exported data” folder on the FTP Area

e Click on Start Task

Task Complete :EBxport successfull : File ‘task 15591 export 582 20181029 1038.zip' is available on the 'Exported_data' FTP folder
Show Task

Your data is compressed in a zip or a tsv file named automatically depending to the format that you selected :

“task_numberofthetask_export_numberlDoftheproject AAAAMMDDoftheexport_ HHMMoftheexport.zip”

ettt ee e st sne e eanens =) o LoT 5 {1 o V=TSP PPRPP zip”
ettt ee e st sne e eanens eXPOrt_detailled_......oooocieeee e e e e et a e zip”
et s =2 4o o] 5 fl ¢ =Te (1] ol=To IS zip”



° Connect your FTP

Host : plankton.obs-vlfr.fr
Username : ftp_plankton
Password : Pl@nktOn4Ecotaxa

74 ftp_plankton@plankton.ob

File Edit View Transfer Server Bookmarks Help MNew version available!
R b LY TR
Host: ilankton.obs-vifrfr  Username: ftp_plankton Passworgd: eeesesssesssesse Do B

. Access to your data by clicking on Ecotaxa_Exported_data folder
J Drag and drop your file into your computer
Remote site: | /Ecotaxa_Exported_data
=2 "
2. AFB_Iroise
- 3 AWI Nicole
2, BCRE
-+ BIOS
2R
-} | Ecotaxa Exported_data
= 7] Tgenenc
- 4 IFCB_Takuvik
. IFREMER
- 3 INIP
Filename Filesize Filetype Last modified ) Permissions Owner/Gro...
gtask_15524_expDrtlmg_lﬁg_Z(]lEl(]ZS_lGS?‘z\p 269880699 Archive WinRAR ZIP 10/25/2018 10:59:00 AM -TW-rwW-nw- 3333
gtask_lﬁﬂél_expurt_d etailed_20181025_00_10.zip 161650 Archive WinRAR ZIP 10/25/2018 12:10:00 AM ~TW- W= T- 3333
BB task_15502_export_detailed_20181024_21_27 zip 25009608 Archive WinRAR ZIP 10/24/2018 9:29:00 PM -TW-rW-rw- 3333
B task _15405_export_1363_20181024_1746.zip 207679 Archive WinRAR ZIP 10/24/2018 5:46:00 PM -IW-rW-rw- 3333
BB task 15468 _exportimg_583 20181024 1438.zip 1126840091  Archive WinRAR ZIP 10/24/2018 2:41:00 PM - W= PW- - 3333
BB task 15459 _export reduced 20181024 01 54.zip 12686870 Archive WinRAR ZIP 10/24/2018 1:54:00 AM - W= PW- - 3333
B task 15167_export_detailed 20181016 14 37 zip 23782 Archive WinRAR ZIP 10/16/2018 2:37:00 PM -TW- W= 3333
BB task_15153_export_149_20181016_1019.zip 460 485005  Archive WinRAR ZIP 10/16/2018 10:28:00 AM - TW- W= 3333
gtask_lﬁlﬁl_expDrt_149_20181(]15_10(]9.z|p 1581070 Archive WinRAR ZIP 10/16/2018 10:09:00 AM ~TW- W - - 3333
gtask_lﬁl!lﬁ_expDrt_ﬁH_ZGlSl(]lE_GQGG.le 11649608 Archive WinRAR ZIP 10/16/2018 9:00:00 AM -TW-rwW-nw- 3333
| task_14528_export_summary_950_20180917_2049.tsv 1056 Fichier TSV 9/17/2018 8:49:00 PM ~TW- W= T- 3333

7. Memory management
After the exportation of your data, delete your files from the FTP.

=>» Anyone having these writing permission on our FTP can load and download any data from this FTP. It is thus
IMPORTANT to remove your data as soon as it has been exported.



